# No network provider accepted the given network path | Endpoint Central MSP Also applicable for **Endpoint Central MSP** ### Problem The Endpoint Central MSP agent/Distribution server installation, patch scanning and remote control have failed. The error message that you see on the screen is, "No network provider accepted the given network path". ### Cause This error could be due to one or more of the following reasons: - You do not have access to admin$ of the client system - You are unable to ping the client system through FQDN - File and print sharing for Microsoft Networks is not enabled - File and printer sharing is disabled in the Windows firewall of the client systems - Security policies are not configured - Workstation services are not running in the client systems. - TCP/IP NetBIOS Helper services are not running in the client systems - You have not opened the following ports in the firewall of the client systems: - 135 - 139 - 445 **Note:** - The causes and resolutions that are explained in this article are based on our experiences in our production and client environments. However, there may still be a few unknown causes. In case this article does not resolve your issue and if you have an Active Directory based network, you can [automate agent installation](https://www.manageengine.com/desktop-management-msp/help/device-onboarding/agent_installation_windows_gpo.html) using a startup script. - The resolution provided in this article will help solve problems faced while trying to complete manual patch scanning and inventory scanning. However, this solution could fail to work in some cases, due to various reasons. Hence it is recommended to perform scheduled [patch](https://www.manageengine.com/desktop-management-msp/scheduled_patch_scanning.html) and [inventory scanning](https://www.manageengine.com/desktop-management-msp/help/inventory/inventory-management-how-to.html). ### Resolution You can resolve this problem as follows: **Check your access to admin$ of the client systems** To check your access to admin$ of the client systems, follow the steps given below: 1. In the computer where the Endpoint Central MSP server is installed, click **Start>Run** 2. Enter `\\\admin$` 3. Click **OK** If you get the same error, enable the **Remote Administration Exception** option in the client systems. Follow the steps given below: 1. In the client system, click **start>Run** 2. Enter **gpedit.msc** 3. Click **OK** 4. Expand **Administrative Templates>Network>Network Connections>Windows Firewall** 5. Click the **Domain Profile** 6. Double click the **Windows Firewall : Allow remote administration exception** option 7. Select **Enabled** 8. Click **OK** You have successfully enabled the remote administration exception option in the client systems. **Ping the client system using a Fully Qualified Domain Name (FQDN)** Ensure that you are able to ping the client systems from the system where the Endpoint Central MSP server is installed using a fully qualified domain name (example hostname.domainname.com). **Enable File and Printer Sharing for Microsoft Networks** You are required to enable the file and printer sharing option for the Microsoft networks in the client systems. Follow the steps given below: 1. Click **start>Settings>Network Connections** 2. Right click on network connection>select **Properties** 3. In the **Local Area Connection Properties** dialog box, select the **General** tab 4. Select the **File and Printer Sharing for Microsoft Networks** checkbox 5. Click **OK** **Note:** If you do not find this option, you are required to install the file and printer sharing option. To install the file and printer sharing option for Microsoft networks, follow the steps given below: 1. Click **start>Settings>Network Connections** 2. Right click on **Network Connection**>select **Properties**. 3. In the **Local Area Connection Properties** dialog box, select the **General** tab 4. Click **Install** 5. Select **Service** 6. Click **Add** 7. In the **Network Service** section, select **File and Printer Sharing for Microsoft Networks** 8. Click **OK** 9. Click **Close** You have succssfully installed the file and printer sharing option for Microsoft networks. **Enable File and Printer Sharing in the Windows firewalls of the client systems** You are required to enable the file and printer sharing option in the Windows firewalls of the client systems. Follow the steps given below: 1. Click **start>Settings>Control Panel>Windows Firewall** 2. Select the **Exceptions** tab 3. Select the **File and Printer Sharing** check box 4. Click **OK** You have successfully enabled the file and printer sharing option in the Windows firewalls of the client systems. If you still get the error that no network provider has accepted the given network path, do the following: - Verify if you are configuring the file and printer sharing option in the same profile that the Endpoint Central MSP server computer is using - Check the profile using which the Endpoint Central MSP server is installed. In some cases, if the profile used to enable the file and printer sharing option in the domain is different from the one used to install Endpoint Central MSP, the file and printer sharing option may not be enabled in the standard profile. You can use the Netsh tool to determine the following information: - System profile using which the Endpoint Central MSP server is installed. - Profile using which you have enabled the file and printer sharing option Alternatively, you can enable the file and printer sharing option for all profiles. To do this, follow the steps given below: 1. Click **start>Run** 2. Enter `cmd` 3. Enter `netsh firewall set service type = FILEANDPRINT mode = ENABLE scope = ALL profile = ALL` 4. Press **Enter** You have successfully enabled the file and printer sharing option for all profiles. **Configure the security policy** To configure the security policy in the system, follow the steps given below: 1. Click **start>Settings>Control Panel>Administrative Tools** 2. Double click **Local Security Policy>Local Policies>Security Options** 3. Double click **Network security: LAN Manager authentication level** 4. Select **Send LM and NTLM responses** 5. Click **OK** You have successfully configured the security policy in the system. **Start the workstation service in the client computers** You are required to start the workstation service in the client computers. Follow the steps given below: 1. Select **start>Settings>Control Panel>Administrative Tools>Services** 2. Right click **Workstation**>**Start** You have successfully restarted the workstation service in the client computers. **Start the TCP/IP NetBIOS Helper service in client computers** 1. Select **start>Settings>Control Panel>Administrative Tools>Services** 2. Right click **TCP/IP NetBIOS Helper**>**Start** You have successfully started the TCP/IP NetBIOS helper service in client computers. **Open the required ports** You are required to open the following ports in the firewalls of the client systems: - 135 - 139 - 445 **Applies to:** Agent/Distribution server installation failure, patch scan failure, asset scan failure, Endpoint Central MSP agent/Distribution server installation, Remote Control