SSL Certificate hostname mismatch
Problem
You are trying to enroll a mobile device with Mobile Device Manager Plus or manage an enrolled mobile device and you get the error message "SSL Certificate hostname Mismatch".
Cause
You might get this error message, if the host name in the certificate does not match with host name configured in NAT settings. This could be due to one of the following reasons:
- Host address specified in the SSL certificate is not same as the Host address mentioned in the NAT settings.
- Self-Signed certificate might not be generated properly while saving the NAT settings.
Resolution
- You should verify the SSL certificate, if the host name mentioned in the certificate is same as the one specified in NAT settings. If it is not the same, either modify the SSL certificate or the NAT settings appropriately.
- If you are using a self-signed certificate, then go to the Mobile Device Manager Plus web console, where you have configured the NAT settings and click Save. By clicking save, a new self-signed certificate will be regenerated automatically.
Applies to: SSL, Self-Singed Certificate
Keywords: MDM, Third Party SSL, Enroll mobile device.