# Windows DHCP Options Reference Manual Search Windows DHCP options and review option IDs, data types, multi-value support, vendor classes, DHCP type, examples, and descriptions. | Option Name | Multi Valued | Data Type | Option ID | Vendor Class | Description | DHCP Type | Example | |---|---|---|---|---|---|---|---| | Classless Static Routes | 0 | `BinaryData` | `121` | `null` | Destination, mask and router IP addresses in priority order | `dhcpd` | `null` | | Subnet Mask | 0 | `IPv4Address` | `1` | `null` | Subnet mask in network byte order | `dhcpd` | `0.0.0.0` | | Time Offset | 0 | `DWord` | `2` | `null` | UTC offset in seconds | `dhcpd` | `0` | | Router | 1 | `IPv4Address` | `3` | `null` | Array of router addresses ordered by preference | `dhcpd` | `0.0.0.0` | | Time Server | 1 | `IPv4Address` | `4` | `null` | Array of time server addresses, by preference | `dhcpd` | `0.0.0.0` | | Name Servers | 1 | `IPv4Address` | `5` | `null` | Array of name servers [IEN 116], by preference | `dhcpd` | `0.0.0.0` | | DNS Servers | 1 | `IPv4Address` | `6` | `null` | Array of DNS servers, by preference | `dhcpd` | `0.0.0.0` | | Log Servers | 1 | `IPv4Address` | `7` | `null` | Array of MIT_LCS UDP log servers on subnet | `dhcpd` | `0.0.0.0` | | Cookie Servers | 1 | `IPv4Address` | `8` | `null` | Array of cookie servers, RFC 865 | `dhcpd` | `0.0.0.0` | | LPR Servers | 1 | `IPv4Address` | `9` | `null` | Array of RFC 1179 servers, by preference | `dhcpd` | `0.0.0.0` | | Impress Servers | 1 | `IPv4Address` | `10` | `null` | Array of Imagen Impress Servers | `dhcpd` | `0.0.0.0` | | Resource Location Servers | 1 | `IPv4Address` | `11` | `null` | Array of RFC 887 ResLoc Servers on subnet, by preference | `dhcpd` | `0.0.0.0` | | Host Name | 0 | `String` | `12` | `null` | Host name for client, RFC 1035 character set | `dhcpd` | `null` | | Boot File Size | 0 | `Word` | `13` | `null` | Size of boot image file in 512-octet blocks | `dhcpd` | `0` | | Merit Dump File | 0 | `String` | `14` | `null` | Path name for crash dump file | `dhcpd` | `null` | | DNS Domain Name | 0 | `String` | `15` | `null` | DNS Domain name for client resolutions | `dhcpd` | `null` | | Swap Server | 0 | `IPv4Address` | `16` | `null` | Address of client's swap server | `dhcpd` | `0.0.0.0` | | Root Path | 0 | `String` | `17` | `null` | Path name for client's root disk, char set NVT ASCII | `dhcpd` | `null` | | Extensions Path | 0 | `String` | `18` | `null` | tftp file for option extensions | `dhcpd` | `null` | | IP Layer Forwarding | 0 | `Byte` | `19` | `null` | Disable/enable IP packet forwarding on this client | `dhcpd` | `0x00` | | Nonlocal Source Routing | 0 | `Byte` | `20` | `null` | Disable/enable nonlocal datagrams | `dhcpd` | `0x00` | | Policy Filter Masks | 1 | `IPv4Address` | `21` | `null` | Destination/mask IP address pairs to filter source routes | `dhcpd` | `0.0.0.0` | | Max DG Reassembly Size | 0 | `Word` | `22` | `null` | Maximum size datagram for reassembly by client; max 576 | `dhcpd` | `0` | | Default IP Time-to-live | 0 | `Byte` | `23` | `null` | Default TTL for client's use on outgoing DGs | `dhcpd` | `0x00` | | Path MTU Aging Timeout | 0 | `DWord` | `24` | `null` | Timeout in seconds for aging Path MTU values; RFC 1191 | `dhcpd` | `0` | | Path MTU Plateau Table | 1 | `Word` | `25` | `null` | MTU discovery sizes, sorted by size, all >= 68 | `dhcpd` | `0` | | MTU Option | 0 | `Word` | `26` | `null` | MTU discovery size, >= 68 | `dhcpd` | `0` | | All subnets are local | 0 | `Byte` | `27` | `null` | The client assumes that all subnets are local | `dhcpd` | `0x00` | | Broadcast Address | 0 | `IPv4Address` | `28` | `null` | Broadcast address | `dhcpd` | `0.0.0.0` | | Perform Mask Discovery | 0 | `Byte` | `29` | `null` | The client should use ICMP for subnet mask discovery. | `dhcpd` | `0x00` | | Mask Supplier Option | 0 | `Byte` | `30` | `null` | The client should respond to subnet mask requests via ICMP. | `dhcpd` | `0x00` | | Perform Router Discovery | 0 | `Byte` | `31` | `null` | The client should solicit routers using RFC 1256. | `dhcpd` | `0x00` | | Router Solicitation Address | 0 | `IPv4Address` | `32` | `null` | Address to use for router solicitation | `dhcpd` | `0.0.0.0` | | Static Route Option | 1 | `IPv4Address` | `33` | `null` | Destination/router address pairs, in priority order | `dhcpd` | `0.0.0.0` | | Trailer Encapsulation | 0 | `Byte` | `34` | `null` | The client should negotiate use of trailers (RFC 983). | `dhcpd` | `0x00` | | ARP Cache Timeout | 0 | `DWord` | `35` | `null` | Timeout in seconds for ARP cache entries | `dhcpd` | `0` | | Ethernet Encapsulation | 0 | `Byte` | `36` | `null` | 0=>client should use ENet V2; 1=> IEEE 802.3 | `dhcpd` | `0x00` | | TCP Default Time-to-live | 0 | `Byte` | `37` | `null` | TTL that client uses when sending TCP segments | `dhcpd` | `0x00` | | Keepalive Interval | 0 | `DWord` | `38` | `null` | Keepalive timeout in seconds | `dhcpd` | `0` | | Keepalive Garbage | 0 | `Byte` | `39` | `null` | Send garbage octet | `dhcpd` | `0x00` | | NIS Domain Name | 0 | `String` | `40` | `null` | Name of Network Information Service domain | `dhcpd` | `null` | | NIS Servers | 1 | `IPv4Address` | `41` | `null` | Addresses of NIS servers on client's subnet | `dhcpd` | `0.0.0.0` | | NTP Servers | 1 | `IPv4Address` | `42` | `null` | Addresses of Network Time Protocol servers | `dhcpd` | `0.0.0.0` | | Vendor Specific Info | 0 | `BinaryData` | `43` | `null` | Embedded vendor-specific options | `dhcpd` | `null` | | WINS/NBNS Servers | 1 | `IPv4Address` | `44` | `null` | NBNS Address(es) in priority order | `dhcpd` | `0.0.0.0` | | NetBIOS over TCP/IP NBDD | 1 | `IPv4Address` | `45` | `null` | NetBIOS over TCP/IP NBDD address(es) in priority order | `dhcpd` | `0.0.0.0` | | WINS/NBT Node Type | 0 | `Byte` | `46` | `null` | 0x1 = B-node, 0x2 = P-node, 0x4 = M-node, 0x8 = H-node | `dhcpd` | `0x00` | | NetBIOS Scope ID | 0 | `String` | `47` | `null` | NetBIOS over TCP/IP Scope ID | `dhcpd` | `null` | | X Window System Font | 1 | `IPv4Address` | `48` | `null` | Array of X Windows font servers | `dhcpd` | `0.0.0.0` | | X Window System Display | 1 | `IPv4Address` | `49` | `null` | Array of X Windows Display Mgr servers | `dhcpd` | `0.0.0.0` | | Lease | 0 | `DWord` | `51` | `null` | Client IP address lease time in seconds | `dhcpd` | `0` | | Renewal (T1) Time Value | 0 | `DWord` | `58` | `null` | Time between addr assignment to RENEWING state | `dhcpd` | `0` | | Rebinding (T2) Time Value | 0 | `DWord` | `59` | `null` | Time from addr assignment to REBINDING state | `dhcpd` | `0` | | NIS+ Domain Name | 0 | `String` | `64` | `null` | The name of the client's NIS+ domain. | `dhcpd` | `null` | | NIS+ Servers | 1 | `IPv4Address` | `65` | `null` | A list of IP addresses indicating NIS+ servers | `dhcpd` | `0.0.0.0` | | Boot Server Host Name | 0 | `String` | `66` | `null` | TFTP boot server host name | `dhcpd` | `null` | | Bootfile Name | 0 | `String` | `67` | `null` | Bootfile Name | `dhcpd` | `null` | | Mobile IP Home Agents | 1 | `IPv4Address` | `68` | `null` | Mobile IP home agents in priority order | `dhcpd` | `0.0.0.0` | | Simple Mail Transport Protocol (SMTP) Servers | 1 | `IPv4Address` | `69` | `null` | List of SMTP servers available to the client | `dhcpd` | `0.0.0.0` | | Post Office Protocol (POP3) Servers | 1 | `IPv4Address` | `70` | `null` | List of POP3 servers available to the client | `dhcpd` | `0.0.0.0` | | Network News Transport Protocol (NNTP) Servers | 1 | `IPv4Address` | `71` | `null` | List of NNTP servers available to the client | `dhcpd` | `0.0.0.0` | | World Wide Web (WWW) Servers | 1 | `IPv4Address` | `72` | `null` | List of WWW servers available to the client | `dhcpd` | `0.0.0.0` | | Finger Servers | 1 | `IPv4Address` | `73` | `null` | List of Finger servers available to the client | `dhcpd` | `0.0.0.0` | | Internet Relay Chat (IRC) Servers | 1 | `IPv4Address` | `74` | `null` | List of IRC servers available to the client | `dhcpd` | `0.0.0.0` | | StreetTalk Servers | 1 | `IPv4Address` | `75` | `null` | List of StreetTalk servers available to the client | `dhcpd` | `0.0.0.0` | | StreetTalk Directory Assistance (STDA) Servers | 1 | `IPv4Address` | `76` | `null` | List of STDA servers available to the client | `dhcpd` | `0.0.0.0` | | Microsoft Disable Netbios Option | 0 | `DWord` | `1` | `Microsoft Options` | Option for enabling or disabling Netbios for Microsoft Windows 2000 Clients | `dhcpd` | `1` | | Microsoft Release DHCP Lease On Shutdown Option | 0 | `DWord` | `2` | `Microsoft Options` | Option for enabling or disabling Windows 2000 Clients to release DHCP lease on shutdown | `dhcpd` | `1` | | Microsoft Default Router Metric Base | 0 | `DWord` | `3` | `Microsoft Options` | Default Router Base Metrics for Microsoft Windows 2000 Clients | `dhcpd` | `1` | | Microsoft Disable Netbios Option | 0 | `DWord` | `1` | `Microsoft Windows 2000 Options` | Option for enabling or disabling Netbios for Microsoft Windows 2000 Clients | `dhcpd` | `1` | | Microsoft Release DHCP Lease On Shutdown Option | 0 | `DWord` | `2` | `Microsoft Windows 2000 Options` | Option for enabling or disabling Windows 2000 Clients to release DHCP lease on shutdown | `dhcpd` | `1` | | Microsoft Default Router Metric Base | 0 | `DWord` | `3` | `Microsoft Windows 2000 Options` | Default Router Base Metrics for Microsoft Windows 2000 Clients | `dhcpd` | `0` | | SIP Server Domain Name List | 1 | `String` | `21` | `null` | Domain Name of SIP servers available to the client | `dhcpd6` | `null` | | Domain Search List | 1 | `String` | `24` | `null` | Domain search list used by clients to resolve hostnames with DNS, by preference | `dhcpd6` | `null` | | NIS Domain List | 1 | `String` | `29` | `null` | Domain names of NIS servers available to the client | `dhcpd6` | `null` | | NIS+ Domain Name List | 1 | `String` | `30` | `null` | Domain names of NIS+ servers available to the client | `dhcpd6` | `null` | | SIP Servers IPv6 Address List | 1 | `IPv6Address` | `22` | `null` | IPv6 addresses of SIP servers available to the client | `dhcpd6` | `null` | | DNS Recursive Name Server IPv6 Address List | 1 | `IPv6Address` | `23` | `null` | IPv6 Addresses of DNS recursive name servers available to the client | `dhcpd6` | `null` | | NIS IPv6 Address List | 1 | `IPv6Address` | `27` | `null` | IPv6 Addresses of NIS servers available to the client | `dhcpd6` | `null` | | NIS+ IPv6 Address List | 1 | `IPv6Address` | `28` | `null` | IPv6 Addresses of NIS+ servers available to the client | `dhcpd6` | `null` | | SNTP Servers IPv6 Address List | 1 | `IPv6Address` | `31` | `null` | IPv6 Addresses of SNTP servers available to the client | `dhcpd6` | `null` | | Information Refresh Time | 0 | `DWord` | `32` | `null` | This option specifies an upper bound for how long a client should wait before refreshing information retrieved from DHCPv6 Server | `dhcpd6` | `86400` |