Issues with using outdated or older devices.

Problem

Some mobile devices enrolled into Mobile Device Manager Plus are using a much older security protocol standard, causing the following error message to be displayed.

Kindly note that this issue occurs only on devices that have been enrolled before the year 2018.

Cause

A few minor enhancements have been made to introduce a new security protocol. Due to a few restrictions, devices running on the old security protocol will have to be migrated such that the new standard of security can be leveraged on them. Enrolling these devices again ensures that you don't run into issues that affect your device management routine.

Resolution

To avoid issues with managing devices, we recommend that you enroll the old devices into MDM management again, so that the devices are in the framework of the new security standards. You can enroll the devices using an enrollment method of your choice, based on your organization's requirements.

  • On the pop-up displayed, click on the here button.
  • A list of all the old devices using the previous security standards will be listed.
  • Re-enroll the devices back into MDM management to continue managing them.
  • Assign users to the devices once the enrollment process is completed.

Note: If you are using the Cloud version of Mobile Device Manager Plus, the devices must be re-enrolled before August 16th, 2022.

To view a list of all the different enrollment methods we offer, refer to this document. While re-enrolling the devices, if you face any issues or have any related queries, contact support.