Troubleshoot an API authentication failure error when integrating InsightVM (Cloud)

Problem

At times, authentication for the Rapid7 InsightVM (Cloud) API fails with the error API authentication failed due to empty data, which can arise from a variety of factors.

Cause

This can occur due to any of the following causes:

  • There are currently no assets available on the InsightVM cloud server.
  • Insufficient permission for accessing assets.
  • The region code for the InsightVM cloud server is incorrect.

Resolution

  • Add assets to the InsightVM server for integration with the Patch Manager Plus.
  • Obtain asset permission from the InsightVM admin user.
  • Ensure the entry of a valid region code. To learn more about the Rapid7 supported regions, click here.

Kindly contact support for any queries.