# "File and Folder Operations" Configuration Failure - Access Denied Last Updated On: 18 Sep 2026 ## Problem You are trying to copy/move/rename/delete files or folders by applying the "File and Folder Operation" configuration on Users/Computers. However you get an error message - "Configuration Failed" in the configuration status having "Access is Denied" as the error details corresponding to the user/computer name for the respective configurations. ## Cause Endpoint Central Application will show this error if one or more of the following issues exist: **Source File/Folder related Issues:** 1. The client(user/computer) does not have necessary permissions to access the Network Share where source file/folder is located. 2. File and Folder Operations is performed on a workgroup environment or between computers in different domains, but no credential has been specified while defining the configuration. 3. In case of Delete Operation, the source file/folder is being used by some other process. **Destination Location related Issues:** 1. In case of User Configuration, the user may not have Write Permissions on the Destination Location. 2. The file/folder on the client machine is being used by some other process. ## Resolution **Resolve Source File related issues:** 1. Ensure the network share storing the source file/folder has permissions to Everyone group. You can check this as follows: For Windows: Right Click Network Share folder > Select *Properties* option > Click *Security* tab > Check if *Everyone* group has *Read* permissions. Else select and apply. For Mac: Right Click Network Share folder > Select *Get Info* option > Click *Sharing and Permissions* tab > Check if *Everyone* group has *Read* permissions. Else select and apply. 2. If you are performing the file/folder operation on a workgroup setup or between computers in different domains, you should specify a user credential to access the source files while defining the configuration. The user credential that you specify, should have necessary privileges to copy or move the files/folders. To modify the configuration, follow the steps below: 1. Select the Configurations tab. This will list all the configurations that have been defined. 2. Clcik the modify icon from the actions column pertaining to the File/Folder operation. 3. Under the Define Configuration Setion, specify a valid user credential that have access to the source file within the "Connect Network Share using Credentials" and redeploy the configuration. 3. In case of Delete operation, ensure the file/folder is not being used any other process. Reboot the client computer and try re-deploying the configuration. If the configuration still fails with same error, then some process may be using the file/folder at system startup itself. In that case, remove the file/folder path from the start-up options. In Windows, the following steps will help you achieve this: Goto *Start* > *Run* > Type *msconfig* and click *OK* > Remove the file/folder path from the *Services/Startup* options of *System Configuration Utility Window*. **Resolve Destination Location related issues:** 1. For User Configuration, ensure the User excercises Write Permissions on the Destination Location. You can check this as follows: Right Click Destination folder > Select *Properties* option > Click *Security* tab > Check if the User has *Write* permissions. Else select and apply. 2. Ensure the file/folder is not being used any other process. Reboot the client computer and try re-deploying the configuration. If the configuration still fails with same error, then some process may be using the file/folder at system startup itself. In that case, remove the file/folder path from the start-up options. In Windows, the following steps will help you achieve this: Goto *Start* > *Run* > Type *msconfig* and click *OK* > Remove the file/folder path from the *Services/Startup* options of *System Configuration Utility Window*.