Troubleshooting errors in Windows Updates

Click here for troubleshooting steps related to similar issues faced by Patch Manager Plus users.

Problem

At times, you may encounter an error during the installation of the Windows updates.

Cause

The issue occurs when one or more Windows Update component files become corrupted or go missing. This corruption prevents the system from properly detecting, downloading, or installing new updates. As a result, the update process may repeatedly fail or get stuck during installation. In some cases, users may also see errors related to update services or damaged system files. This typically indicates an integrity problem within the Windows Update components. The issue occurs when one or more Windows Update component files become corrupted or go missing. This corruption prevents the system from properly detecting, downloading, or installing new updates. As a result, the update process may repeatedly fail or get stuck during installation. In some cases, users may also see errors related to update services or damaged system files. This typically indicates an integrity problem within the Windows Update components.

Resolution

Follow the steps given below to resolve this issue:

For Windows Dot Net updates

  • Search for patch ID 108183 - Microsoft .NET Framework Repair Tool in the supported patches list.

    If you are not able to find the patch ID, go to Patch Database Settings -> Windows -> enable the Optional Updates checkbox. After enabling, search for the patch ID in the supported patches list.

  • Select the patch and click on Install patch.
  • Deploy the configuration on the failed targets.
  • Once the configuration is executed successfully, retry the deployment of the failed patches.

If the issue still exists,

  • Uninstall and reinstall the .NET framework version installed.
  • Then restart the system, perform a patch scan and deploy the failed patches if it still appears in the missing patches list.
  • If still the issue persists, then follow the resolution for Windows OS updates.

For Windows OS updates

  • Search for patch ID 105979 - Component Store Corruption in the supported patches list.

    If you are not able to find the patch ID, go to Patch Database Settings -> Windows -> enable the Optional Updates checkbox. After enabling, search for the patch ID in the supported patches list.

  • Select the patch and click on Install patch.
  • Deploy the configuration on the failed targets.
  • Once the configuration is executed successfully, retry the deployment of the failed patches.

If the issue still persists, deploy the Windows update component restore patch from using Endpoint Central,

  • Deploying Windows update component restore patch will not impact any data on the target computers, and will only resolve issues in the operating system (if any).

    This applies only to the systems running Windows 10 and Windows 11, excluding server machines. For assistance with server machines, please contact the vendor.

To deploy Windows update component restore patch, follow the steps given below:

Downloading the ISO file

You can also download the ISO from Microsoft Software Download center provided that you have a license key to deploy the package.

  • Ensure that the editions, architecture, version, and OS languages of your target computers are the same as the downloaded ISO file.

Deploying Windows update component restore patch using Endpoint Central

Operating System Version Update ID Description
Windows 10 22H2 110870 Windows update component restore for Windows 10 (22H2)
22H2 110041 Dependency Patch for Windows 10 (22H2) - October 2022 Update (x64) (Manual Upload Required)
Windows 11 21H2 111125 Windows update component restore for Windows 11 (21H2)
21H2 109021 Dependency Patch for Windows 11 (21H2) - October 2021 Update (x64) (Manual Upload Required)
Windows 11 22H2 111126 Windows update component restore for Windows 11 (22H2)
22H2 109939 Dependency Patch for Windows 11 (22H2) - September 2022 Update (x64) (Manual Upload Required)
Windows 11 23H2 111127 Windows update component restore for Windows 11 (23H2)
23H2 110949 Dependency Patch for Windows 11 (23H2) - October 2023 Update (x64) (Manual Upload Required)
Windows 11 24H2 111893 Windows update component restore for Windows 11 (24H2) (Deployment-Only)
24H2 111890 Dependency Patch for Windows 11 (24H2) - October 2024 Update (x64) (Manual Upload Required)
Windows 11 25H2 112755 Windows update component restore for Windows 11 (25H2) (Deployment-Only)
25H2 112733 Dependency Patch for Windows 11 (25H2) (x64) (Manual Upload Required)

Note: After deploying the Windows update component restore patches, restart the system before proceeding with any further deployments to ensure successful implementation.

  • In the product console, navigate to Patches -> Downloaded Patches -> Upload Patches and select All Patches in the filter.

    win-updates

  • Browse and select the required patch and click on Upload from the Action column.
  • win-updates

  • Upload the ISO file, choose a Checksum type, and enter the checksum value.

    win-updates

  • Once the checksum is validated, click on Upload and to calculate checksum, refer here.
  • Once the dependency patch has been uploaded, you can deploy the Windows update component restore patches to agents from the Supported Patches view on the console.