Agent Installation - Knowledge base

A device attached to the system is not functioning 

Problem

You can see the error message "A device attached to the system is not functioning" on the screen when you try to do either of the following:

  • During image creation, when the hard disk of the machine where image is created is not functioning.
  • During image creation/deployment, when the hardisk of the image repository machine is not functioning.
  • During deployment, when the hard disk of the machine where image is deployed is not functioning.

 Cause

  1. The machine/hard disk is switched off.
  2. The machine/hard disk is not connected properly.
  3. The hard disk and drive type are not compatible.
  4. The hard disk is not properly inserted in the drive.
  5. The hard disk is not properly formatted. 

Resolution

To resolve this problem, follow the steps given below:

  1. Ensure that you have rebooted the machine where this error is displayed.
  2. Check the device manager of the machine for any hard disk related errors and resolve the same.
  3. Ensure that the drivers in the machine are updated.
  4. Ensure that the date and time in image creation machine and image repository machine are the same.
  5. To check if there are any errors in the hard disk execute the following commands with administrative privilege in the command prompt,

    For OS upto windows vista - sfc /scannow

    For Windows OS 7 and above - DISM /Online /Cleanup-Image /RestoreHealth

Keywords: hard disk not functioning, image repository machine, image creation machine.