ServiceDesk Plus MSP Settings return "Invalid Authentication Key"

Problem

You are trying to integrate RMM Central and ServiceDesk Plus MSP applications. When you specify an authentication key, you see the error 'Invalid Authentication Key'. When you want to install or uninstall software applications and log help desk requests as tickets using ServiceDesk Plus, you are required to generate and enter an authentication key while integrating RMM Central with ServiceDesk Plus MSP. You must make the following settings to generate an authentication key:

Cause

You will see this error in the following cases:

  • Specified authentication key is no longer valid or has expired. If you have set the key to expire after sometime, check the expiry date.
  • Authentication key has been regenerated by a ServiceDesk Plus MSP technician
  • ServiceDesk Plus MSP technician for whom the key was generated has been deleted
  • Technician creation has not been saved after generating the API key

Prerequisites

  • Ensure that you have ServiceDesk Plus MSP administrator role to generate Authentication key.

Resolution

You are required to generate a new authentication key in ServiceDesk Plus MSP and specify it in RMM Central. To generate a new API key in ServiceDesk Plus, follow the steps given below:

  1.  Generating Authentication key
    1. Log in to ServiceDesk Plus MSP
    2. Go to Personalize tab available in the top pane
    3. Click API key Generation
    4. Specify the date of expiry
    5. Click Generate

      Note: This key is entered when a technician key is required for web service API requests.

    6. Click Save

      Note: You can also edit an existing technician's role and enable login.

  2. Pasting the API key in RMM Central.
    1. Login to the web console.
    2. Click the Admin tab
    3. In the Integrations section, click ServiceDesk Plus MSP Settings
    4. Modify the ServiceDesk Plus MSP server details, enter the generated API key and save.