Knowledge Base - WSUS Compatibility Error!

Problem

While configuring WSUS settings you get an error - "WSUS console version is not equal to the WSUS Server version".

Cause

You might get this error due to the following reason:

  1. Patch Connect Plus installed machine does not contain the required WSUS console version
  2. The version of WSUS console in Patch Connect Plus installed machine is not the same as WSUS server version. 

Resolution

The table given belows shows the operating systems where Patch Connect Plus can be installed based on the primary WSUS Server.

WSUS server OS WSUS Version OS where Patch Connect Plus can be installed
Windows server 2016 10.0.14393.x Windows 10, Windows server 2016.
Windows server 2012 R2 6.3.9600.x Windows 8.1, Windows server 2012 R2.
Windows server 2012 6.2.9200.x Windows 8, Windows server 2012.
Windows server 2008 R2 & below 3.x Windows 7, Windows vista, Windows XP, Windows Server 2008 R2 & below

Follow the below steps to check for WSUS server version,

  1. Go to the machine where you have installed WSUS server
  2. Open WSUS server console
  3. In the left hand side, under Update Services select the WSUS server name. 
  4. Refer the below image to find the server version.

    wsus server

  5. Similarly find the WSUS console version in the Patch Connect Plus installed machine.
  6. Now check if both the versions are matching. If not using the below data update the WSUS console version in Patch Connect Plus installed machine.

    For WSUS installed in Windows server 2008 R2 and below

Installed Update Version
WSUS 3.0 (RC) 3.0.6000.318
WSUS 3.0 (RTW) 3.0.6000.374
WSUS 3.0 (SP1) 3.1.6001.65
WSUS 3.0 (SP1 + KB954960) 3.1.6001.66
WSUS 3.0 (SP2 Beta) 3.2.7000.84
WSUS 3.0 (SP2 RC) 3.2.7085.146
WSUS 3.0 (SP2) 3.2.7600.226
WSUS 3.0 (SP2 + KB2720211) 3.2.7600.251
WSUS 3.0 (SP2 + KB2734608) 3.2.7600.256

In case if this problem continues, kindly Contact Support

Keywords: Third-party Patch Management, WSUS Server compatibility, Server versions