Knowledge Base - TeamViewer patch download failure

 

Problem

You are trying to download TeamViewer 14 (MSI), TeamViewer 15 (MSI) and TeamViewer Host 15 (MSI) patches and the download fails, with an error message that says Patch Download Failure.

Cause

The downloads are available only to customers who have purchased the license.

Resolution

Follow the steps below, to successfully publish updates to SCCM via Patch Connect Plus.

  1. Download the updates of TeamViewer and TeamViewer Host manually.
  2. If you're using a Patch Connect Plus build version 90065 or above
    • You'll be able to find an option to 'Upload and Publish now' near the Download failed error message. Using this option you can publish the patch.
  3. upload and publish

  4. If you're using a Patch Connect Plus build version below 90065
    • Navigate to the \webapps\ROOT\store
    • To patch "teamviewer.exe", create a new folder and paste the downloaded TeamViewer update.
    • TeamViewer Host 15: 69a20f44-78e0-4443-a3f1-71ed21838bf9
    • TeamViewer 15: 2f9ab753-b61f-4996-b407-a0cbce18b5b0
    • TeamViewer 14: 701b9b03-10fa-4c41-b475-645a1dee9286
    • In the Download failed Patches view in the Home page, select the updates, click Download and Publish Now.

In case if this problem continues, kindly Contact Support

Keywords: TeamViewer 14 & 15 patch download failure