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1. Introduction

1.1 Overview

Group Policy is a collection of settings used to add additional controls to the working environment of
both user and computer accounts. Group Policy helps enforce password policies, deploy patches,
disable USB drives, disable PST file creation, and more. Group Policy helps strengthen your
organizations' IT security posture by closely regulating critical policies such as password change,

account lockout, and more.

1.2 Benefits of auditing Group Policy Objects using ADAudit Plus

® Audit, alert, and report on Group Policy Object (GPO) creation, deletion, modification,

history, and more.
® Monitor who made what setting changes to your GPOs and from where in real time.
e Generate granular reports on the new and old values of all GPO setting changes.

® Keep a close eye on critical policy changes like changes to account lockout policy and password

change policy to detect and respond to malicious activities instantly.

® And much more.

2. Supported systems

2.1. Supported Windows Server versions

Windows Server 2008, 2008 R2, 2012, 2012 R2, 2016, 2016 R2, 2019, and 2022.

3. Configuring domain controllers

3.1 Automatic process
Check whether the configured domain controller is a primary domain controller (PDC)

using the following steps.

1. Login to any computer with Active Directory Users and Computers.
2. Go to Start > Windows Administrative Tools > Active Directory Users and Computers.
3. Right-click on the domain and select Operations Masters.

4. In the operations master window that opens, click the PDC tab at the top.
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5. Under Operations master is the name of the server configured as the PDC.

6. Click Close.

7. Open ADAudit Plus.

8. Click Domain Settings in the top right corner.

9. Under Available Domain Controllers, ensure that the PDC has been configured.

10. If not, Select +Add Domain Controllers, and choose one.

Note: If ADAudit Plus is unable to discover your domain controller, you can manually type it in.

11. Click Save.
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o= 2 8|6 -
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7] Active Directory Users and C| D OC  Infrastructure
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_ Builtin "
ainer for do...
| Computers Operations master:
2 Domain Controllers |adap-ws adap workshop com ‘ )
51 donotDelete | ainer for sec...
ForeignSecurityPrinci To transfer the operations master role to the following -
= T 9 e compuiter, click Change. m
3] Laps adap-ws.adap workshop.com ‘ ainer for ma..
| Managed Service Acc
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2| Workshop
Close Cani

Notes:
® Ensure that the share path W'machine_name"\sysvol is accessible from the machine

that has ADAudit Plus installed on it.

e To perform GPO setting change auditing, you only need to configure the PDC.
GPO management auditing, on the other hand, requires configuring all the domain controllers

that have been licensed.
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4. Configuring the audit policies

4.1 Automatic process
Configure the audit policies automatically using the steps below:

1. Open ADAudit Plus.
2. Go to Admin > Domain Settings. Click Audit Policy: Configure in the top-right corner.

Note: ADAudit Plus can automatically configure the required audit policies for GPO auditing.
After clicking Audit Policy: Configure in the above step, you can either choose Yes to let ADAudit Plus

automatically configure the required audit policies, or choose No to manually configure them.

ADAudit Plus ) Heme Reports File Audit Server Audit Analytics Alerts Configuration Ademin Si Q Search.. O Domain Settings
Configured Domain(s) + Add Domain
adap.workshop.com= adap.internal = L] ~
Available Domain Controllers Audit Policy :Configure
@ oW i 1lof1 25 T Filter
ACTIONS DOMAIN CONTROLLER NAME = EVENT FETCH INTERVAL TIMESTAMP OF LAST EVENT LAST EVENT READ TIME STATUS
T B adap-dcl Every 2 hours Aug 07,2019 05:37:28 PM Aug 07.2019 05:26:21 PM [Run Now

+ Add Domain Controller

4.2 Manual process
Configure the audit policies manually using the steps below:
1. Using domain admin credentials, log in to any computer that has the Group Policy Management

Console (GPMC) on it.

Note: The GPMC will not be installed in workstations and/or enabled in member servers by default.

Hence, we recommend configuring audit policies in Windows domain controllers.
2. Go to Start > Windows Administrative Tools > Group Policy Management.

3. In the GPMC, select Domains and choose the domain you want to configure Group Policy for.

Select Domain Controller, right-click the Default Domain Controllers Policy, and select Edit.
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4. In the Group Policy Management Editor, follow the steps below:

Note: Advanced audit policy configuration will only be available in Windows Server 2008 or later.

If you have an older version of Windows, configure legacy audit policies.

Advanced audit policies

5. Choose Computer configuration > Policies > Windows Settings > Security settings >

Advanced Audit Policy Configuration > Audit Policies.

6. Click, enable, and save the audit policies as shown below:

Category Subcategory
DS Access Audit Directory Service Access Success
Audit Directory Service Changes Success
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Local audit policies

7. Choose Computer configuration > Policies > Windows Settings > Security Settings >

Local Policies > Audit Policies.

8. Click, enable, and save the audit policies as shown below:

Local audit policy

Audit events

Category

Audit directory service access

| 1/ Group Policy Management Editor
File Action View Help
+| @ m
11 Seripts (Startup/Shutden
= Deployed Printers
~ [y Security Settings
v i Account Policies
5 Password Policy

» 18 Account Lockout Policy
» 8 Kerberos Policy
v i Local Pelicies
+ Ji Audit Policy
+ i User Rights Assignment
» i Security Options
» & Eventlog
A Restricted Groups
4 System Services
@ Registry
5 File System
i Wired Network (IEEE 802.3) Policies
2| Windows Firewall with Advanced Se
| Network List Manager Policies
i Wireless Network (IEEE 802.11) Pelic
 Public Key Policies
- Software Restriction Policies
| Application Control Policies
» 8 1P Security Policies on Active Directc
~ 1 Advanced Audit Policy Configuratio
& Audit Policies

» dll Policy-based QoS vl

chicy

< Audit account logon events
s Audit account management
a Audit directory service access
s, Audtt logon events

| Audit object access

i Audit policy change

wa Audit privilege use

| Audit process tracking

wal Audit system events

Success

Policy Setting

Success, Failure
Success, Failure
Success
Success, Failure
Success
Success

Not Defined
Success
Success
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5. Configuring object-level auditing

5.1 Automatic process

Automatic configuration of object-level auditing requires the user's consent.

To configure object-level auditing automatically:

1. Open ADAudit Plus.

2. Go to Reports > GPO Management > GPO History > Object-level auditing needs to be

configured for getting proper reports: Configure.

5.2 Manual process
Configure object-level auditing manually using the steps below:

1. Using domain admin credentials, log in to any computer that has Active Directory Users

and Computers on it.
2. Go to Start > Windows Administrative Tools > Active Directory Users and Computers.
3. Click View > Advanced features.
4. Right-click on the domain, and go to Properties > Security > Advanced > Auditing > Add.

5. In the Auditing Entry window, click Select a principal. Under Enter the object name to select,

type in Everyone, and click OK.

Principal:
Select User. Computer. Service Account. or Group X
s - Select thes cbiect type
Applies to: | This object and all descendant objects User. Group. or Buiktin securty principal | | Object Types..
From this location |
‘adap workshop com Locations |
Permissions: Enter the cbisct name 10 sabect (exampies)
|svenune\ Chack Mames
|
tancnd ool | |

6. Select Type: Success. Select the appropriate permissions as directed below.
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Note: Use Clear all to remove all permissions and properties before selecting the appropriate permissions.

Auditing Auditing

entry for

entry number

3and 4 GPO

Apply to Windows
Server 2003

This object and all
child objects

Create groupPolicy
Container objects

Delete groupPolicy
Container objects

groupPolicyContainer
objects

Write all properties
Delete

Modify permissions

Apply to Windows
Server 2008/Windows
Server 2012

This object and all
descendant objects

Descendant groupPolicy
Container objects

Permission Entry for adap m) Y
I
Principak  Everyone Select a principa
Type Allow -
Applies to: | This object and all descendant objects w
Permissions:
[ Full control [[] Delete msimaging-PSPs objects
4] List contents [[] Create MSMQ Queue Alias cbjects
] Read all properties [ Delete MSMQ Queue Alias objects
[ Write all properties [[] Create mePKI-Key-Recovery-Agent objects
=] Delete [[] Delete mePKI-Key-Recovery-Agent objects
[] Delete subtree [[] Create msSFU30MailAliases objects
[[] Read permissions [[] Delete msSFUZ0MailAhaces objects
EA Medify permissions [ Create msSFU30Netid cbjects
7 Modify owner [[] Delete msSFUZ0Metid objects
[ Al validated writes [ Create msSFU30NetworkUser objects
[C] Al extended rights [[] Delete msSFUZ0NetworkUser objects
[] Create all child objects [] Create msTPM-InformationObjectsContainer objects
[[] Delete all child objects [[] Delete msTPM-InformationObjectsContainer objects
] Create Computer abjects [C] Create nisMap objects
[[] Delete Computer objects [C] Delete nisMap objects
[] Create Contact objects [[] Create nisNetgroup objects W
Cancel

6. Configuring security log size and retention settings

6.1 Configuring security log size
Configure security log size for Group Policy audit data using the steps below:
1. Go to Start > Windows Administrative Tools > Group Policy Management.

2. In GPMC, right-click the GPO "domain name"_ADAudit Plus Audit policy, and select Edit.

3. In the Group Policy Management Editor, choose Computer configuration > Policies >

Windows settings > Security settings > Event Log > Retention Method for Security Log.
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4. Check Define these policy settings, and select Overwrite events as needed.

5. Click OK.

| Group Policy Managerment Editor
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b e 4 1 XE =
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w Windows Setting:
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f_{ Local Palic

| Eventlog

4 Restricted
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@ Registry

@ File Systen

i Wired Net

Windows |

1 Network L

i Wireless N

Public Key

Software F

Applicatio

B 1P Security
Advanced ,

< tT >

B

Policy

-l Maimum application log size

.| Maximum security log size

-] Maximum system log size

_| Prevent local guests group from accessing application log
| Prevent local guests group from accessing security log

_:| Prevent local guests group from accessing system log

_z| Retain application log

| Retain security log

_| Retain system log

_| Retention method for application log
|55 Retention method for security log

— Retention method for system log

6.2 Configuring retention settings

Policy Setting
Not Defined
Net Defined
Mot Defined
Not Defined
Not Defined
Mot Defined
Mot Defined
Mot Defined
Mot Defined
Not Defined
Not Defined
Not Defined

Configure retention settings for Group Policy audit data using the steps below:

1. Open ADAudit Plus.

2. Go to Admin > Configuration > Archive events and check the GPO Management box.

Then enter the number of Days and Reclaimable space.

3. Choose the Archive folder.

4. Click Save.

7. Installing the Group Policy Management Console (GPMC)

The GPMC must be installed on the machine used to run ADAudit Plus. Install GPMC in the

machine running ADAudit Plus using the steps below:

For Windows Server 2012 and above

1. Go to Start > Control Panel, and select Turn Windows features on and off under Programs.

2. In the Add Roles and Feature Wizard window that opens, select Features.

3. Check Group Policy Management, and click Next.

4. Click Install.
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For Windows Server 2008 and 2008 R2

1. Go to Start > Control Panel, and select Turn Windows features on and off under Programs.
2. In the Server manager window select Features > Add features.
3. Check Group Policy Management, and click Next.

4, Click Install.

Note: Once the GPMC is installed, open ADAudit Plus console > Reports > GPO Settings Changes >
Group Policy Settings Changes. An error message will be displayed on top that says "Please install
GPMC in the computer where ADAudit Plus is installed. After you install GPMC please Click here."
Go ahead and click the Click here hyperlink to begin advanced GPO report generation in ADAudit Plus.

Our Products

AD360 | Log360 | ADManager Plus | ADSelfService Plus | DataSecurity Plus | M365 Manager Plus
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ManageEngine ADAudit Plus is an IT security and compliance solution. With over 200 event-specific reports and

real-time email alerts, it provides in-depth knowledge about changes effected to both the content and configuration

of Active Directory, Azure AD and Windows servers. Additionally it also provides thorough access intelligence for

workstations and file servers (including NetApp and EMC).

To learn more about how ADAudit Plus can help you with all your Active Directory auditing needs, please visit:

https://www.manageengine.com/products/active-directory-audit/
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