Patch Installation Failure - File hash Mismatch - 0x80246002

Problem

When installing deployed patches in client machines through SCCM, the installation fails with error code -0x80246002 and with the error message "A download manager operation could not be completed because the file digest was not recognized".

Cause

This error will occur when there is a file hash mismatch between downloaded file and deployment package in the client machine. This is due to the old deployment file of the same update, existing in the ccmcache folder.

Resolution

To resolve this issue, follow the steps mentioned below.

  1. On the Patch Connect Plus console, navigate to SCCM -> Third Party Updates.
  2. Select the updates which are failed to deploy and click on Re-Sign.

  3. pcp-resign

     

  4. On the SCCM console, navigate to Software Library -> Overview -> Patch Connect Plus -> Third Party Updates.
  5. Ensure the Date Released or Revised of the selected patches are updated to the current date and time in the patch Detail view.

  6. sccm-con

     

  7. Then Right-click on Deployment package and select Show Members

  8. Patch installation failure

     

  9. Select the Deployment option.

  10. Patch installation failure

     

  11. Delete the Deployment.

  12. Patch installation failure

     

  13. Delete the Package as well.

  14. Patch installation failure

     

  15. After deleting the deployment and package, make sure that the columns Downloaded and Deployed are marked No.

  16. Patch installation failure

     

  17. Once the above steps are completed, kindly create a new deployment.

In case of any further clarifications, reach out to our Support team

Keywords: Third-party Patch Management, Installation Error, Patch Failure.