Microsoft 365 audit sync errors

This document provides a list of common error messages that can occur when collecting SharePoint Online audits, along with their respective solutions. Click on an error message to navigate to its solution.

Below is the list of errors while fetching SharePoint Online audit data:

If your error message is not listed above, please reach out to support@sharepointmanagerplus.com

Error: The permission set () sent in the request does not include the expected permission

Missing permissions error in SharePoint Manager Plus

Figure 1: Missing permissions error in SharePoint Manager Plus.

Cause: The Azure application doesn't have the required API permissions to fetch the audit data.

Solution:

  1. Navigate to Admin tab > Microsoft 365 and copy the Client ID under the Azure Application column for your respective tenant.
  2. Getting the client ID to configure an Azure application in SharePoint Manager Plus

    Figure 2: Getting the client ID.

  3. Open the Microsoft Entra admin center portal and navigate to Microsoft Entra ID > App Registrations > All applications.
  4. Search using the copied Client ID and open the corresponding application.
  5. Open API permissions and click Add a permission.
  6. In the pop-up, navigate to Office 365 Management APIs > Application permissions.
  7. Select ActivityFeed.Read and click Add permissions.
  8. Click Grant admin consent for <Your Company> and give confirmation.
  9. Granting admin consent for the application in the Entra admin center

    Figure 3: Granting admin consent for the application in the Entra admin center

Error:

Note: The CN value (e.g., "Zscaler Root CA") may vary depending on the certificate in use.

Untrusted certificate error in SharePoint Manager Plus

Figure 4: Untrusted certificate error in SharePoint Manager Plus.

Cause: This error occurs when the certificate used for authentication, firewall, or proxy is not trusted by the product's Java Runtime Environment (JRE).

Solution: To rectify this error, the certificates must be added to the JRE's trusted certificate store.

To identify the certificate to import to the keystore:

  1. Note the CN value displayed in the error message.
  2. Open the Certificate Management tool by running certmgr.msc from the Run dialog, or by searching for Manage User Certificates in the search bar.
  3. Certificate management console

    Figure 5: Certificate management console.

  4. Navigate to Trusted Root Certification Authorities in the left-pane, and click Certificates. A list of trusted certificates will be displayed.
  5. List of trusted certificates

    Figure 6: List of trusted certificates.

  6. From the list of certificates, identify the CN noted in Step 1, in the Issued By column.
  7. List of issued certificates and their corresponding issuing authorities.

    Figure 7: List of issued certificates and their corresponding issuing authorities.

  8. Once identified, click on the certificate to export it.
  9. A pop-up will open as shown below:
  10. Certificate details window

    Figure 8: Certificate details window.

  11. Navigate to the Details tab.
  12. Click Copy to File. A Certificate Export Wizard will open. Click Next.
  13. Certificate export wizard

    Figure 9: Certificate export wizard.

  14. Select the certificate format DER encoded binary X.509 (.CER), and click Next.
  15. Specify the file name and path to export (for example: D:\Trusted Root.cer), and click Next.
  16. Click Finish. The certificate will be exported to the specified path.

To add the certificate to the trust store:

  1. Navigate to <product_installation_directory>/jre/bin.
  2. Open Command Prompt as an administrator.
  3. Run the following command:

    keytool.exe -import -trustcacerts -alias "certAlias" -file "certPath" -keystore ..\lib\security\cacerts

    • Where certAlias is a name of your choice and certPath is path where the certificate is stored.
  4. You will be prompted for a password. The default password is changeit. Provide the password and press Enter.
  5. Restart the product.

Errors:

Cause:

The product is trying to fetch SharePoint Online audit data using the Search-UnifiedAuditLog PowerShell cmdlet. This cmdlet requires Exchange Online module dependency and has resulted in data inconsistencies for certain users.

Solution:

From build 4501 and above, you can choose to use the Office 365 Management Activity API. Update to the latest build using the service pack and follow the steps given in this document to use the Management API to fetch SharePoint Online data.

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