Fehlerbehebung bei fehlgeschlagenem Download von Metadatendateien des Paketmanagers

Problem 1:

  1. Hinweis nach einem erfolgreichen Scan — Metadatendateien des Linux-Paketmanagers fehlen auf dem Server.
  2. Hinweis nach einem fehlgeschlagenen Deployment — Das Deployment ist fehlgeschlagen, da Metadatendateien des Linux-Paketmanagers auf dem Server fehlen.

Ursache:

Das Problem kann durch einen fehlgeschlagenen Download der Metadatendateien des Linux-Paketmanagers verursacht werden oder dadurch, dass die Dateien auf dem Server noch nicht heruntergeladen wurden.

Lösung:

Die folgenden Schritte helfen Ihnen bei der Behebung des Problems, wenn Dateien auf dem Verteilungs-Server fehlen:

  1. Überprüfen Sie den Status der DS-Replikation auf etwaige Fehler:
    • Wechseln Sie in der Endpoint Central-Konsole zur Registerkarte „Agent“, wählen Sie im Abschnitt „Verwaltungsbereich“ die Option „Remote Offices“ aus und überprüfen Sie den DS-Synchronisierungsstatus sowie die Hinweise. Im Falle von Fehlern wenden Sie sich bitte an den Support, um weitere Unterstützung zu erhalten.
  2. Wechseln Sie zu Threats & Patches --> Jetzt aktualisieren und starten Sie eine Synchronisierung der Patch-DB, um die Metadatendateien des Paketmanagers zu aktualisieren.
  3. Setzen Sie die unten genannten Domains auf die Whitelist in der Firewall/dem Proxy-Server:
  4. Setzen Sie die unten genannte Dateierweiterung auf die Whitelist in der Firewall/dem Proxy-Server:
    • .gz
    • .xz
    • .gpg
  5. Wechseln Sie dann zu Threats & Patches, wählen Sie Jetzt aktualisieren und klicken Sie auf Downloadneu initiieren, um die Metadatendateien des Linux-Paketmanagers abzurufen.
     

    package-manager-files

  6. Nach dem erfolgreichen Download der Metadatendateien des Linux-Paketmanagers können Sie mit dem Scan oder den Patch-Deployments fortfahren.

Problem 2:

  1. Hinweis nach einem erfolgreichen Scan — Metadatendateien des Linux-Paketmanagers fehlen auf dem Verteilungs-Server.
  2. Hinweis nach einem fehlgeschlagenen Deployment — Das Deployment ist fehlgeschlagen, da Metadatendateien des Linux-Paketmanagers auf dem Verteilungs-Server fehlen.

Ursache:

Im Folgenden sind die möglichen Ursachen für Problem 2 aufgeführt:

  • Kommunikationsprobleme zwischen dem Verteilungs-Server und dem Server.
  • Probleme bei der Replikation von Dateien auf den Verteilungs-Server.

Lösung:

Die folgenden Schritte helfen Ihnen bei der Behebung des Problems, wenn Dateien auf dem Verteilungs-Server fehlen:

  1. Überprüfen Sie den Status der DS-Replikation auf etwaige Fehler.
  2. Wechseln Sie dann zu Threats & Patches --> Jetzt aktualisieren und prüfen Sie den Status der letzten Aktualisierung der Metadatendateien des Linux-Paketmanagers. package-manager-files1
    • Wenn der Download fehlschlägt, setzen Sie die genannten Domains auf die Whitelist und klicken Sie dann auf Downloadneu initiieren, um die Metadatendateien des Linux-Paketmanagers abzurufen.
    • Wenn der Download noch läuft, warten Sie, bis er erfolgreich abgeschlossen ist.
  3. Nachdem die Dateien auf den Server heruntergeladen wurden, warten Sie den nächsten Replikationszyklus ab und stellen Sie sicher, dass die Dateien erfolgreich auf den Verteilungs-Server (DS) repliziert wurden, bevor Sie mit dem Scan oder den Patch-Deployments fortfahren.
  4. Wenn Metadatendateien des Linux-Paketmanagers auf dem Verteilungs-Server für die Oracle-Variante fehlen, stellen Sie sicher, dass die Schritte zur DS-Replikation befolgt wurden.

Weitere Unterstützung:

Falls Sie den Fehler nicht beheben können und das Problem weiterhin besteht, wenden Sie sich mit den Protokolldateien an das Support-Team.

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