Schedule demo
 
 

CVE-2018-7890

Unauthenticated remote code execution vulnerability


Vulnerability Details
Impact CVSS V3 rating: 9.8 CRITICAL
Reported 07 March 2018
Fixed 12 March 2018
Affected Builds Till Build 13630
Fixed in Build 13640
Overview Unauthenticated remote code execution vulnerability
Recommended Fix Upgrade to Applications Manager Version 13640 or above.

Description

A remote code execution issue was discovered in Applications Manager before build 13640. The publicly accessible testCredential.do endpoint takes multiple user inputs and validates supplied credentials by accessing a specified system. This endpoint calls several internal classes, and then executes a PowerShell script. If the specified system is OfficeSharePointServer, then the username and password parameters to this script are not validated, leading to Command Injection.

We recommend that you upgrade to Applications Manager Version 13640 or above to fix this issue.


Source and Acknowledgements

Find out more about CVE-2018-7890 from the CVE dictionary and NIST NVD.

Other Resources:  https://pentest.blog/advisory-manageengine-applications-manager-remote-code-execution-sqli-and/

Need Help?

For clarification or corrections please contact our support team or email us at appmanager-support@manageengine.com

You're in great company