Kiosk profile not applicable

Problem

You are trying to install an MDM Kiosk profile to a managed device and you get an error message "Kiosk profile not applicable". 

Cause

 This error occurs when the Kiosk profile is pushed to Android devices which do not support Kiosk.

Resolution

Ensure the device to which the Kiosk profile is being pushed is:

  1. Samsung devices running 4.0 and later versions.
  2. Android devices running 5.0 and later versions, provisioned as Device Owner.

Learn how to provision a device as Device Owner using NFC with MDM MSP and MDM MSP Cloud

Applies to: Kiosk, Android Enrollment, Managing Mobile Devices

Keywords: Profile failure, Mobile Device Management, Kiosk profile