Issues with installation of Windows app

Problem

You are trying to distribute and install apps on Windows devices and the installation fails.

Cause

This could happen due to various reasons, such as:

Resolution

Problems with package signature

Ensure that the apps have been signed with trusted code signing certificates and Windows Sideloading policy is enabled on the mobile devices.

Other reasons may include

  • The package is unsigned
  • The publisher name does not match the signing certificate subject.

Dependent files are missing

Ensure all the required dependent files have been uploaded to the server when the apps are distributed. Missing dependent files hamper the app installation and updates.

Mismatch in the installed package

While installing an app update, the package being installed might not match with the installed package.

  • Ensure the digital signature is still a part of the new package.
  • Increment the version number of the app, rebuild, resign the app and distribute it to the devices again
  • Remove the existing app from the device and redistribute the new app package to the devices

User has removed the app

Ask the user the reinstall the app from the App Catalog on their mobile devices, if they have uninstalled the app.

 

If you're still unable to resove the issue, contact MDM MSP Support (msp-mdm-support@manageengine.com).

 
Applies to: Scanning the mobile device, Distributing Apps, Associating Profiles

Keywords: MDM scanning, Associating profiles, Mobile Device Management