Troubleshooting errors in Windows Updates

Click here for troubleshooting steps related to similar issues faced by Endpoint Central users.

Problem

You might get one of the following error messages when you try to install windows updates:

  • Cannot find object or property
  • Catastrophic failure
  • No signature was present in the subject
  • No such interface supported
  • Element not found
  • The component store has been corrupted
  • The referenced assembly could not be found
  • The system cannot find the file specified
  • The system does not support the command requested
  • One or more required members of the transaction are not present
  • Unknown Error. Code : -2145124329 - Operation was not performed because there are no applicable updates
  • Unknown Error. Code : -1073740791
  • Unknown Error. Code : -2068578302
  • Unknown Error. Code : -2068578304
  • Unknown Error. Code : -2068709375
  • Unknown Error. Code : -2145124297
  • Unknown Error. Code : -2145124322
  • Unknown Error. Code : -2146498302
  • Unknown Error. Code : -2146498511
  • Unknown Error. Code : -2147021879
  • Unknown Error. Code : -2147024894
  • Unknown Error. Code : -2146498170
  • Unknown Error. Code : -2145124348

Cause

Windows updates and service packs may fail to install if there are corruption errors. For example, an update might not install if a system file is damaged. 

Resolution

Follow the steps given below to resolve this issue:

For Windows Dot Net updates

 
  • Search for patch ID 108183 - Microsoft .NET Framework Repair Tool in the supported patches list.
  • If you are not able to find the patch ID, go to Patch Database Settings -> Windows -> enable the Optional Updates checkbox. After enabling, search for the patch ID in the supported patches list.

  • Select the patch and click on Install patch.
  • Deploy the configuration on the failed targets.
  • Once the configuration is executed successfully, retry the deployment of the failed patches.

If the issue still exists,

  • Uninstall and reinstall the .NET framework version installed.
  • Then restart the system, perform a patch scan and deploy the failed patches if it still appears in the missing patches list.
  • If still the issue persists, then follow the resolution for Windows OS updates.

For Windows OS updates

 
  • Search for patch ID 105979 - Component Store Corruption in the supported patches list.
  • If you are not able to find the patch ID, go to Patch Database Settings -> Windows -> enable the Optional Updates checkbox. After enabling, search for the patch ID in the supported patches list.

  • Select the patch and click on Install patch.
  • Deploy the configuration on the failed targets.
  • Once the configuration is executed successfully, retry the deployment of the failed patches.

FAQ

1) What the troubleshooting patch will do?

The patch for troubleshooting errors in Windows Updates will:

  1. Restart the Windows update service in the system.
  2. Backup and delete the SoftwareDistribution folder available in the windows directory.
  3. Run System File Checker (SFC) tool to check and fix the corrupted system files.
  4. If the Operating system is Windows 8 and above,
    Perform component store cleanup and scan the Windows image for any corruption and perform a repair automatically using Deployment Image Servicing and Management (DISM) tool.

2) What does Microsoft .NET Framework Repair Tool do?

The Microsoft .NET Framework Repair Tool is a free utility provided by Microsoft that is designed to diagnose and repair problems with the .NET Framework installation on a Windows computer.

In case you're not able to troubleshoot the errors, and the problem persists, kindly contact support.