Connection to the Mobile Device Manager Plus server is not secure

Problem

The connection to the server shows "Your connection is not private" despite enabling https communication.

Cause

There are three possible reasons for this error to pop-up.

  1. If the server host name is not listed under the (Subject Alternative Name) SAN name of the certificate.

  2. If the validity period of the certificate uploaded has expired.

  3. If the trusted root certificate is not present on the computer using which the server is accessed.

Resolution

  1. If the server host name is not available inside the certificate, users can use the available SAN entries or upload a certificate with the host names under SAN values required for accessing the server.
  2. For certificate expiration, users should upload a new certificate.
    Note:The certificates should have a validity period of 397 days maximum. Visit this page to learn how to generate a certificate.
  3. You can upload the trusted root certificates on machines which will be used to access the Central server. To upload a trusted root certificate:

For Windows machines:

  • Navigate to server installed directory, /apache/conf.
  • Open the DMRootCA.crt file.
  • Upload your trusted root certificates to the Trusted Root Certification Authorities.
  • Clear the browser cache and open the server.

For Mac machines:

Exporting the certificate to a Mac machine:

  • Navigate to server installed directory, /apache/conf.
  • Open the DMRootCA.crt file.
  • Click Details > Copy to File > Click Next > Click Base 64 encoded > Choose Export Location and Name > Click Next > Click Finish.
  • The certificate will now be successfully exported with .cer extension.

Installing the certificate on a Mac machine:

  • Open Keychain access on a Mac machine.
  • Click + option and import the certificate.
  • Open the imported file and enable the trust option in the certificate.
  • Select 'always trust' and upload the certificate.