How to choose the required criteria while creating a rule?

There are 3 different criteria available while creating a compliance rule:

  • Simple Criteria
  • Advanced Criteria
  • Advanced Custom Criteria
Simple Criteria Advanced Criteria Advanced Custom Criteria
To check the presence or absence of a single line or a group of lines in the configuration file.
 Example:
Check if the configuration contains all of the following lines:
snmp-server community public RO
snmp-server community private RW
Network Configuration Manager goes about checking the lines (specified by you) one-by-one against the configuration file.
To specify more complex criteria using Regular Expression.
Example:
Check if enable secret is configured
enable secret 5 $1$3Jcu$sB3
In the above example, the single digit number and other characters that follow enable secret will differ in each case. So, simple criteria cannot be used here to check if "enable secret" has been properly configured. Thus, Advanced criteria must be used.
To define the beginning and the end of the required configuration blocks for selective compliance check. This is just an extension of 'Advanced Criteria'.
Example:
Check if description is written for all the interface blocks
interface FastEthernet0/0
description branch office 1 connectivity
ip address 192.168.118.32 255.255.255.0
service-policy output Stream
!
interface FastEthernet0/1
description branch office 2 connectivity
ip address 192.168.118.32 255.255.255.0
service-policy output Stream
!
There will be many such interface blocks in the device configuration. And, the interface name and the description will vary for each block. So, neither simple criteria nor advanced criteria could be used for creating compliance rule. You need to use 'Advanced Custom Criteria', which will help in checking each configuration block individually.

Simple Criteria:

Criteria Description Example
Should contain all lines The configuration to be checked for compliance should contain all the lines specified by you. Even if a single line is not found, it will be pronounced as 'violation'. Network Configuration Manager goes about checking the lines (specified by you) one-by-one against the configuration file. It is not necessary that the lines should be present exactly in the same order as specified by you. Since the check is done line-by-line, it is enough if the all the lines are present anywhere in the configuration. Criteria: Should contain all lines
Configuration lines to check:
snmp-server community public RO
snmp-server community private RW
Violation:
If any or all the lines are NOT present in the configuration file (irrespective of the order of the presence of the lines)
Should not contain any line Exactly opposite to the above. The configuration to be checked for compliance should NOT contain any of the lines specified by you. Even if a single line is found, it will be pronounced as 'violation'. Network Configuration Manager goes about checking the lines (specified by you) one-by-one against the configuration file. The order of the lines are not important. Criteria: Should not contain any line
Configuration lines to check:
snmp-server community public RO
snmp-server community private RW
Violation:
If any or all the lines are present in the configuration file (irrespective of the order of the presence of the lines)
Should contain exact set This is similar to 'Should contain all lines', but the difference is that the order of the lines is taken into consideration. If you have specified four lines, Network Configuration Manager will go about checking if all the four lines are present in the same order as specified. If the lines are not present exactly as specified, it will be pronounced as rule violation. Criteria: Should contain exact set
Configuration lines to check:
snmp-server enable traps hsrp
snmp-server enable traps config
snmp-server enable traps entity
Violation:
If all the lines are NOT present in the configuration file in the same order (and same set) as specified
Should not contain exact set Exactly opposite to the above. This is similar to 'Should not contain any line', but the difference is that the order of the lines is taken into consideration. If you have specified four lines, Network Configuration Manager will go about checking if the configuration contains the all the four lines in the same order as specified. If the lines are present exactly as specified, it will be pronounced as rule violation. Criteria: Should not contain exact set
Configuration lines to check:
snmp-server enable traps hsrp
snmp-server enable traps config
snmp-server enable traps entity
Violation:
If all the lines are present in the configuration file in the same order (and same set) as specified

Advanced Criteria:
You can use certain Regular Expressions in providing the criteria for checking the configuration for compliance. The following are few examples:

Regular Expression Patterns & Description
Matching specific characters

Characters inside square brackets can be used to match any of the characters mentioned therein.

Example:

[abc] - This is to look for any of the characters a, b or c. The matching is case-sensitive.

Matching a range of characters or numbers

Character range inside square brackets can be used to match any of the characters in the range specified therein. The character range could be alphabets or numbers. The matching is case-sensitive.

Examples:
[a-zA-Z] - This will match any character a through z or A through Z
[0-9] - This will match any digit from 0 to 9

Other Specific Matches
. a dot can be used to match any single character, including space.
d to match any digit from 0 to 9
D to match any character other than a digit (0-9)

s to match a single space character

S to match any character other than space

X? question mark preceded by a character. The character (in the example here 'X') that precedes the question mark can appear at the most once or does not appear at all

X* asterisk preceded by a character. The character (in the example here 'X') can appear any number of times or not at all

X+ plus sign preceded by a character. The character (in the example here 'X') must appear at least once

X|Y characters separated by a pipe symbol. This is to match either first character or the next one. In the example here, this is to match either X or Y

For more details, refer to the "Regular Expression Tutorials" of Java Tutorials.
More Examples:

Description RegEx Pattern
To check if enable secret is configured enable secret d S+ - to match any line containing the text "enable secret" followed by any single digit from 0 to 9 AND any character other than space appearing at least once
To check if there is a 'public' community present in the configuration snmp-server community public RO|RW - to match any line containing the text "snmp-server community public" followed by either "RO" or "RW"
To check if logging to a syslog server has been configured logging S+ - to match any line containing the text "logging" followed by an ip address

 

Criteria Description Example
Should contain The configuration to be checked for compliance should contain the line matching the RegEx pattern specified by you. Criteria: Should contain line(s) as per the RegEx pattern defined
Configuration lines to check:
snmp-server community public RO|RW
Violation: If the line "snmp-server community public" followed by either "RO" or "RW" is NOT present
Should not contain The configuration to be checked for compliance should not contain the line matching the RegEx pattern specified by you. Criteria: Should not contain line(s) as per the RegEx pattern defined
Configuration lines to check:
snmp-server community public RO|RW
Violation: If the line "snmp-server community public" followed by either "RO" or "RW" is present
Usage of AND/OR condition Two or more RegEx patterns defined for 'Should Contain' or 'Should not contain' could be combined through AND/OR conditions --

Advanced Custom Criteria:


As mentioned above, 'Advanced Custom Criteria' is just an extension of 'Advanced Criteria' and it helps in defining the beginning and the end of the required configuration blocks for selective compliance check. Both 'Simple Criteria' and 'Advanced Criteria' are used to check the entire configuration of a device for compliance to a rule. There might be requirements to check specific portions of the configuration for compliance to a rule.
For example, assume that in certain Cisco Switches, the administrator wants to check if description is written for all the interface blocks. So, every single interface block has to be checked for compliance to this rule. The device configuration will have so many interface blocks with different names. Hence, you cannot define a suitable compliance rule to check all the interface blocks using the previous two criteria options - simple and advanced. They will only help in defining a constant rule to check the entire configuration once - not every single interface block.
In such cases, administrators can make use of the 'Advanced Custom Criteria' to achieve this. He can simply define the starting and ending of the interface blocks and create an advanced custom criteria. Once this is done, Network Configuration Manager will split the configuration into configuration blocks and check for compliance. The compliance result for each block will be reported individually. It will then be very simple for the administrator to find which configuration blocks do not have full-duplex connection enabled and take remediation accordingly.
Besides, you can also specify some extra conditions through the "Additional Block Criteria". This gives you the option to exclude any configuration block within the interface block specified above, for compliance check. (See the example below to get better understanding).
Defining the criteria in this case is the same as 'Advanced Criteria'. Thus, the only difference between 'Advanced Criteria' and 'Advanced Custom Criteria' is that the user can define the beginning and the end of the required configuration blocks for selective compliance check.

Specifying the starting and ending of configuration

Consider the following configuration blocks in a Cisco Switch:

interface FastEthernet0/0
description branch office 1 connectivity
ip address 192.168.118.32 255.255.255.0
service-policy output Stream
!
interface FastEthernet0/1
description branch office 2 connectivity
ip address 192.168.118.32 255.255.255.0
service-policy output Stream
!

If you want to check if all the interface blocks have a description configured, you need to specify the 'Configuration Block Start' as interface in the text field. Similarly, for 'Configuration Block End', you can enter "!" in the text field.
You can define the conditions for the rule as explained for 'Advanced Criteria' above. For the particular example of checking the configuration blocks for description, the rule will look like the screenshot below.
In case, you want to exclude the interfaces that were shutdown from carrying out the compliance check, you may include "Additional Block Criteria". In the drop-down against 'Advanced Block Criteria', choose the condition "Should Not Contain" and type the word the word "shutdown" in the text field. When you do so, while checking if all the interface blocks contain description, the shutdown blocks will be left out from the compliance check.